爱皮哇 | 刘大喵blog / zh-CN 爱皮哇是一个网络技术分享站,涉及Linux,华为,H3C,Mikrotik,RouteOS,ROS,路由交换,服务器,WEB,等等,当然也会分享一些建站记录或心得,包括主题/插件/主机,网络工程师,运维 Tue, 03 Sep 2019 21:10:00 +0800 Tue, 03 Sep 2019 21:10:00 +0800 添“钉”发财、又是扎胎的一天...... /678.html /678.html Tue, 03 Sep 2019 21:10:00 +0800 刘大喵 下午近五点点多,正要去参加朋友饭局,准备上高速“嘀嘀、嘀嘀、嘀嘀...”漏气报警响起来了,内心只有一句单词 Shit!!! 只能先区找修车店补胎了,毕竟要上高速...

[collapse status="true" title=""]
zhatai2.jpg
[/collapse]

[collapse status="true" title=""]
zhatai1.jpg
[/collapse]

[collapse status="true" title=""]
zhatai3.jpg
[/collapse]
还好在附件找到了正在关门的修车店 ::paopao:tieba_emotion_08:: 再迟一分钟怕补不了胎了~运气还是挺好的 ::aru:cryingface::

]]>
48 /678.html#comments /feed/678.html
中兴皖通CPE开局配置说明 /673.html /673.html Mon, 26 Aug 2019 19:25:00 +0800 刘大喵 [scode type="green"]
本文要包括CPE的基本配置,不包含CPE的网管通道的打通,CSG到ASG的PW
[/scode]

CPE开局配置说明

第一章 设备名称

1、配置命令
hostname XXXXXX //根据客户提供的命名规范。举例:CPE-GZHW-PYWDGC-2
2、CPE设备命名规范
[collapse status="false" title="点击展开→"]

格式:CPE-地市+CPE厂家-名称-n(n=1,2,3......),n代表该地址所在的第几个CPE。
其中CPE、地市+厂家、名称、n为必选项;
例子:CPE-GZHW-番禺万达广场-1
CPE-GZHW-番禺万达广场-2
CPE-ZHHW-珠海胡景苑-1
1)CPE设备上配置的名称对应中文名称,英文名称为:CPE-GZHW-PYWDGC-2;CPE-ZHHW-ZHHJY-1;
2)如果有名称简称重复的,后面重复设备的最后一个汉字使用全拼小写;例如CPE-ZHHW-ZHHJyuan-1;
3)如果最后一个汉字仍旧重复,后面的两个汉字使用全拼小写,依次类推,例如CPE-ZHHW-ZHHjingyuan-1;
4)地市属性:21个地市首字母,例如广州:GZ。
5)CPE厂家属性:CPE设备厂家首字母。
[/collapse]

第二章 端口

1、主接口配置上联CSG的端口:举例1/6端口

180X

interface gei_1/6
description to_CSG_nantainguangchang0205-3,20170404  //端口描述,to上联设备,日期,
no negotiation auto             //关闭自协商,把端口修改成强制千兆全双工
speed 1000
duplex full

180P/380H-8

interface gei-0/5
 description to_CSG_nantainguangchang0205-3,20170404  //端口描述,to上联设备,日期,
 negation negation-force         //关闭端口自协商,把端口改成强制千兆全双工
 speed speep-1g
 duplex duplex-full

2、CPE管理地址配置,使用上联CSG的端口,子接口固定使用99
180X

interface gei_1/5.99 
 description for_CPE_manamger   //端口增加描述信息 for_用途
 enc dot1q 99    //管理vlan 99
 ip address x.x.x.x 255.255.255.252    //根据规划配置管理ip,掩码30; CSG/ASG使用低位地址,CPE使用高位地址;由UTN专业分配地址;

180P/380H-8:

interface gei-0/5.99 
 description for_CPE_manamger   //端口增加描述信息 for_用途
 ip address x.x.x.x 255.255.255.252    //根据规划配置管理ip,掩码30; CSG/ASG使用低位地址,CPE使用高位地址;由UTN专业分配地址;
 vlan-configuration
interface gei-0/5.99
 encapsulation-dot1q 99

5、CPE配置loopback1地址

interface loopback1
ip address x.x.x.x 255.255.255.255    //根据规划配置CPE的业务loopback地址
exit

第三章 静态路由

1、配置到第三方网管的静态路由

ip route 1.37.127.0 255.255.255.240  X.X.X.X
//其中1.37.127.0/28为CPE网管U31和第三方网管的南向ip地址段;下一跳X.X.X.X为CPE上联到CSG的.99子接口对应的对端设备的对应99子接口的IP地址,例如1.37.185.1。
注意:2+3模型的地市下一跳为ASG设备上管理通道接口ip,纯3模型的地市下一跳为对端CSG管理通道接口ip。

第四章 snmp(设备出厂会默认配置)

180X

no snmp-server community zxwt_rw //删除默认团体名
no snmp-server community zxwt_read //删除默认团体名
snmp-server view lldpView internet included
snmp-server view lldpview iso included  //SNMP MIB视图的信息包括iso子树
snmp-server access-list snmp
snmp-server community GDutnoss view lldpview rw  //写属性包括了读写权限。当读属性团体名与写属性团体名一致时,读属性命令行会被写属性命令行覆盖。
snmp-server trap-source X.X.X.X //设置Trap报文源接口CPE上联端口管理地址。
snmp-server host 1.37.127.2 trap version 2c GDutnoss udp-port 162 //允许向1.37.127.2(第三方网管)发送SNMP Trap报文,使用团体名为GDutnoss。
snmp-server host 1.37.127.4 trap version 2c GDutnoss udp-port 162 //允许向1.37.127.4(U31网管)发送SNMP Trap报文,使用团体名为GDutnoss。
snmp-server enable trap    //使能SNMP发送Trap的功能。
snmp-server enable inform  //使能SNMP发送Trap的功能。

180P/380H-8

no snmp-server community public //删除默认团体名
no snmp-server community private //删除默认团体名
snmp-server view lldpview iso included //SNMP MIB视图的信息包括iso子树
snmp-server community GDutnoss view lldpview rw //写属性包括了读写权限。当读属性团体名与写属性团体名一致时,读属性命令行会被写属性命令行覆盖。
snmp-server enable inform //使能SNMP发送Trap的功能
snmp-server enable trap //使能SNMP发送Trap的功能
snmp-server host 1.37.127.2 trap version 2c GDutnoss  //允许向1.37.127.2(第三方网管)发送SNMP Trap报文,使用团体名为GDutnoss。
snmp-server host 1.37.127.4 trap version 2c GDutnoss  //允许向1.37.127.4(U31网管)发送SNMP Trap报文,使用团体名为GDutnoss。
snmp-server trap-source X.X.X.X //设置Trap报文源接口CPE上联端口管理地址。
snmp-server version v2c enable
logging trap-enable notifications

第五章 log服务器

目前CPE没有部署log服务器;待更新! ::quyin:1huaji::

第六章 本地账号

180X

config模式下
username gdcpe2017 password CPE_gd@@)!&2017 privilege 15  //配置用户名、密码以及优先级,用户名统一为gdcpe2017                                                                                 
username gdcpeoss2017 password CPE_oss@@)!&2017 privilege 15   //第三方网管账户,配置用户名、密码 ,用户名统一为gdcpeoss2017
ssh server enable         //使能ssh服务器

180P/380H-8

configure terminal
multi-user configure
aaa-authentication-template 2001
aaa-authentication-type local
exit
aaa-authorization-template 2001
aaa-authorization-type local
exit
enable secret level 15 zxr10
system-user
authentication-template 1
bind aaa-authentication-template 2001
exit
authorization-template 1
bind aaa-authorization-template 2001
exit
default-privilege-level 15
user-name gdcpe2017
bind authorization-template 1 
bind authentication-template 1
password CPE_gd@@)!&2017
exit
user-name gdcpeoss2017
bind authentication-template 1
bind authorization-template 1
password CPE_oss@@)!&2017
exit
exit
ssh server enable   //使能ssh服务器

测试完新建用户正常使用后,请退出,并进行测试。
180X默认用户名密码需要删除,180P/380H-8在新增用户名之后,原msr/zxr10msr用户名将失效,不用删除。
conftg模式下:(180X)
no username msr  删除默认用户msr

第七章 用户登录

line telnet max-link 15    //配置可以同时登录到设备的VTY类型用户界面的最大个数为15。默认为

第八章 NTP

目前还没有NTP服务器部署,以后会增加。 ::paopao:tieba_emotion_25::

第九章 访问控制策略

180X:
acl standard number 99   //规范使用acl 99;
  description telnet-acl
  rule 1 permit 1.37.127.0 0.0.0.15  //允许网管ip登陆
rule 2 permit source 1.X.X.X  X.X.X.X     //允许CPE上联的CSG或者ASG登录;范围为每个地市分配CPE管理通道地址的地址段。
exit
snmp-server access-list 99
line telnet access-class 99

180P/380H
line telnet  access-class ipv4 1 
ssh server access-class ipv4 1?
ipv4-access-list 1?
rule 1 permit 1.37.127.0 0.0.0.15 
 //允许网管ip登陆
rule 2 permit source 1.X.X.X  X.X.X.X     //允许CPE上联的CSG或者ASG登录;范围为每个地市分配CPE管理通道地址的地址段。
rule 20 permit any
exit
]]>
14 /673.html#comments /feed/673.html
一些Linux的基础练习题 /672.html /672.html Tue, 25 Jun 2019 21:50:00 +0800 刘大喵 1,显示当前时间,格式为:2019-06-18 10:20:30 答案:date “+%F,%T” 或者 date “+%F %H:%M:%S” 2,显示前天是星期几? 答案:date -d “-2 day” +%A 知识点:一 ,date +%s 是把当前时间转化为秒数 二, date -d @”1523604170″ 把秒数转化回来 3,今天18:30自动关机,并提示用户。 答案:hutdown -h 18:30 “dao dian guan ji,18:30” 如果想取消此操作输入: shutdown -c 4,在本机字符终端登录时,除显示原有信息外,在显示当前登录终端号,主机名和当前时间。 答案:vim /etc/profile.d/kaiji.sh 进去后输入:#******************************************************************** echo your hostname is hostname who am i 5,显示/var目录下所有以l开头,以一个小写字母结尾,且中间出现至少一位数字的文件或目录。 答案:ls /var/l*[0-9]*[[:lower:]] 6,显示/etc目录下以任意一位数字开头,且以非数字结尾的文件或目录。 答案:ls /etc/[0-9]*[^0-9] 7,显示/etc/目录下以非字母开头,后面跟了一个字母及其他任意长度任意字符的文件或目录。 答案:ls /etc/[^[:alpha:]][a-zA-Z]* 8,显示/etc/目录下所有以rc开头,并后面是0-6之间的数字,其他为任意字符的文件或目录。 答案:ls /etc/rc[0-6]* 9,显示/etc目录下,所有以.d结尾的文件或目录。 答案:ls /etc/*.d 10,显示/etc目录下,所有.conf结尾,且以m,n,r,p开头的文件或目录。 答案:ls /etc/[m,n,r,p]*.conf 11,只显示/root下的隐藏文件和目录。 只显示/etc下的非隐藏目录 答案:ls -d /root/.* ls /etc/[^.]*/ -d 12,定义别名命令baketc,每天将/etc/目录下的所有文件,备份到/app独立的子目录下,并要求子目录格式为backupYYYY-mm-dd备份过程可见。 答案:alias baketc=”cp -av /etc /data/backupdate +%F” 13,创建/app/rootdir目录,并复制/root下所有文件到该目录内,要求保留原有权限。 答案:mkdir -p /app/rootdir cp -a /root /app/rootdir/ 14,如何创建/testdir/dir1/x,/testdir/dir/y,/testdir/dir/x/a,/testdir/dir/x/b,/testdir/dir/y/a,/testdir/dir/y/b. 答案:mkdir -p /testdir/dir1/{x,y}/{a,b} 15,如何创建/testdir/dir2/x,/testdir/dir2/y,/testdir/dir2/x/a,/testdir/dir2/x/b. 答案:mkdir -p /testdir/dir2/{x/{a,b},y} 16,如何创建/testdir/dir3,/testdir/dir4,/testdir/dir5,/testdir/dir5/dir6,/testdir/dir5/dir7. 答案:mkdir -p /testdir/{dir3,dir4,dir5/{dir6,dir7}} 17,将/etc/issue文件中的内容转化为大写后保存至/tmp/issue.out文件中。 答案:cat /etc/issue | tr “[a-z]” “[A-Z]” > /tmp/issue.out 18,将当前系统登录用户的信息转换为大写后保存至/tmp/who.out文件中。 答案:who | tr “[a-z]” “[A-Z]” >/tmp/who.out 19,一个linux用户给root发邮件,要求邮件标题为” help”,邮件正文如下:Heello,i am 用户名,The system version is here ,please help me to check it,thanks! 操作系统版本信息 答案:mail -s “help” root <<123 >Hello,I am $USER >The system version is here,please help me to check it,thanks! >cat /etc/centos-release >123 20,将/root/下文件列表,显示成一行,并文件名之间用空格隔开。 答案:ls /root | tr “\n” ” ” 21,计算1+2+3+..+99+100的总和。 答案:echo {1..100}|tr ” ” “+”|bc 22,删除Windows文本文件中的^M字符 答案:tr -d “\15” win.txt 23,处理字符串 “xt.,l 1 jr#!$mn 2 c*/fe 3 uz 4” ,只保留其中的数字和空格。 答案:echo “xt.,l 1 jr#hostnamemn 2 c*/fe 3 uz 4” |tr -dc “[:digit:][:space:]” 24,将PATH变量每个目录显示在独立的一行。 答案:echo $PATH |tr “:” “\n” 25,将指定文件中0-9分别代替成a-j . 答案:先创建文件touch f1 给f1 vim 输入0-9 cat f1 | tr “[0-9]” “[a-j]” 26,将文件/etc/centos-release中每个单词(由字母组成)显示在独立的一行,并无空行。 答案:cat /etc/centos-release |tr -c “[:alpha:]” ” ” |tr -s ” ” “\n” 27,创建用户gentoo,附加组为bin和root,默认shell为/bin/csh,注释信息为”Gentoo Distribution”. 答案:useradd -G bin,root -s /bin/csh -c “Gentoo Distribution” gentoo 28,创建下面的用户,组和组成员关系 名字为webs的组 用户nginx使用webs作为附加组 用户varnish,也使用webs作为附加组 用户mysql,不可交互登录系统,且不是webs的成员,nbinx,varnish,mysql密码都是magedu 答案: groupadd webs useradd -G webs nginx useradd -G webs varnish useradd -s /sbin/nologin masql echo magedu |passwd –stdin nginx; echo magedu |passwd –stdin varnish; echo magedu |passwd –stdin mysql; 29,当用户docker对/testdir 目录无执行权限时,意味着无法做哪些操作? 答案: 不能cd进去,不能查看文件详细属性,也不能去访问目录里的文件内容(即使有读权限)。 30,当用户mongodb对/testdir 目录无读权限时,意味着无法做哪些操作? 答案:不能对目录下的文件进行访问。 31, 当用户redis 对/testdir 目录无写权限时,该目录下的只读文件file1是否可修改和删除? 答案:不能,因为对目录没有权限,所以不能。文件能不能删,不由文件决定,而由目录决定。 32,当用户zabbix对/testdir 目录有写和执行权限时,该目录下的只读文件file1是否可修改和删除? 答案:可以修改和删除 33,复制/etc/fstab 文件到/var/tmp 下,设置文件所有者为tomcat 读写权限,所属组为apps组有读写权限,其他人无权限。 答案:(一)cp -a /etc/fstab /var/tmp (二) useradd tomcat (三) groupadd apps (四) chown tomcat /var/tmp (五) chgrp apps /var/tmp (六) chmod 660 /var/tmp 34,误删除了用户git的家目录,请重建并恢复该用户家目录及相应的权限属性。 答案: rm -rf /home/git ; mkdir /home/git; cp -a /etc/skel/.[^.]* /home/git; chown -R git:git /home/git; 35,在/testdir/dir 里创建的新文件自动属于webs组,组apps的成员如:tomcat能对这些新文件有读写权限,组dbs的成员如:mysql只能对新文件有读权限,其他用户(不属于webs,apps,dbs)不能访问文件夹。 答案: mkdir -p /testdir/dir chgrp webs /testdir/dir chmod g=s /testdir/dir setfacl -m g:apps:rw /testdir/dir setfacl -m g:dbs:r /testdir/dir chmod o= /testdir/dir 36,备份/testdir/dir 里所有文件的ACL权限到/root/acl.txt中,清除/testdir/dir中所有ACL权限,最后还原ACL权限。 答案: getfacl -R /testdir/dir > /root/acl.txt setfacl -b /testdir/dir setfacl -R –set-file=acl.txt /testdir/dir 37, 找出ifconfig “网卡名” 命令结果中本机的IPv4地址。 答案:(方法一)ifconfig ens33 | grep netmask | tr -s ” ” “:” |cut -d: -f3 (方法二)ifconfig ens33 |egrep -o \<“(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])”\> (方法三)ifconfig ens33 | sed -n “2p” | sed -r s’@(.*inet)(.*)( netmask.*)@\2@’ 38,查出分区空间使用率的最大百分比值。 答案:(方法一)df | grep ^/dev | tr -s ” ” “:” | cut -d: -f5 |cut -d% -f1 | sort -nr | head -n1 (方法二) df | grep -o “[0-9]\{1,3\}%” |grep -o “[0-9]\+” |sort -nr |head -n1 39,查出用户UID最大值得用户名,UID及shell类型。 答案:cat /etc/passwd |sort -nr -t: -k3 |head -n1 |cut -d: -f1,3,7 40,查出/tmp的权限,以数字方式显示 答案:stat /tmp |head -n4|tail -n1|cut -d/ -f1|cut -d'(‘ -f2 41, 统计当前连接本机的每个远程主机IP的连接数,并从大到小排序。 答案: 先从桌面获取rz 获取文件,再进行处理。 cat access_log |egrep -o “\<(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\>”|sort|uniq -dc|sort -nr 42,显示/proc/meminfo 文件中以大小s开头的行(要求:使用两种方法) 答案:(方法一)cat /proc/meminfo |egrep -oi ^s.* (方法二)cat /proc/meminfo |egrep ^[Ss].* 43,显示/etc/passwd文件中不以/bin/bash结尾的行。 答案:cat /etc/passwd |egrep -v /bin/bash$ 44,显示用户rpc默认的shell程序。 答案:(方法一)cat /etc/passwd |egrep rpc|cut -d: -f1,7 (方法二)cat /etc/passwd |egrep rpc|sed -r ‘s/(.*:)([^:]+:?$)/\2/’ 45,找出/etc/passwd 中的两位或三位数 答案:cat /etc/passwd | egrep -o “[0-9]{2,3}” 46,显示Centos7的/etc/grub2.cfg文件中,至少以一个空白字符开头的且后面有非空白字符的行。 答案:cat /etc/grub2.cfg |egrep ^[[:space:]][^[:space:]].*$ 47,找出”netstat -tan” 命令结果中以LISTEN后跟任意多个空白字符结尾的行。 答案:netstat -tan |egrep .*LISTEN[[:space:]]+ 48, 显示Centos7上所有系统用户的用户名和UID。 答案:cat /etc/passwd |egrep .*/sbin/nologin$ |cut -d: -f1,3 49,添加用户bash,testbash,basher,sh,nologin(其shell为/sbin/nologin),找出/etc/passwd用户名和shell同名的行。 答案:cat /etc/passwd | egrep “^(.*)(:.*)\1$” 50,利用df和grep,去出磁盘各分区利用率,并从大到小排序。 答案:df |grep ^/dev |tr -s ” ” “:”|cut -d: -f5 |cut -d% -f1 |sort -nr|head -n1 51,显示三个用户root,mage,wang的UID和默认shell. 答案:cat /etc/passwd |egrep ^”(root|mage|wang)” |cut -d: -f1,3,7 52,找出/etc/rc.d/init.d/functions文件中行首为某单词(包括下划线)后面跟一个小括号的行。 答案:cat /etc/rc.d/init.d/functions | egrep “^[a-zA-Z_]+ .*” 53,使用egrep取出/etc/rc.d/init.d/functions中其基名。 答案:echo /etc/rc.d/init.d/functions |egrep -o “[^/]*/?$” 54,使用egrep取出上面 路径的目录名。 答案:(方法一)echo /etc/rc.d/init.d/functions |egrep -o “/.*/” (方法二)echo /etc/rc.d/init.d/functions |egrep -o “(/).*\1” 55,统计last命令中以root登录的每个主机IP地址登录次数。 答案: last |egrep root |egrep “\<(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\>”|tr -s ” ” “:”|sort -t: -k3|cut -d: -f3|uniq -dc 56,利用扩展正则表达式分别表示0-9,10-99,100-199,200-249,250-255. 答案: [0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5] 57,显示ifconfig命令结果中所有IPV4地址。 答案: ifconfig | egrep -o “\<(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\>” 58,将此字符串:welcome to magedu linux 中的每个字符去重并排序,重复次数多的放在最前面。 答案: echo “welcometomagedulinux” |grep -o “.”|sort|uniq -c|sort -nr 59,复制/etc/profile至/tmp/目录,用查找替换命令删除/tmp/profile文件中的行首的空白字符。 答案: cp /etc/profile /tmp/ vim /tmp/profile 命令模式下按“:”进入扩展模式输入 %s/^[[:space:]]*//g 60, 复制/etc/rc.d/init.d/functions文件至/tmp目录,用查找替换命令为/tmp/functions的每行开头为空白字符的行的行首添加一个#号。 答案: cp /etc/rc.d/init.d/functions /tmp vim /tmp/functions 命令模式下按“:”进入扩展模式输入 %s/^[[:space:]] */#&/ 或者 %s/[[:space:]]\+.? /#\1/g 61, 在VIM中设置tab缩进为4个字符。 答案: vim /etc/vimrc 在文件最后添加: set ts=4 set expandtab set autoindent :wq 62,复制/etc/rc.d/init.d/functions文件至/tmp目录,替换/tmp/functions文件中的/etc/sysconfig/init为/var/log. 答案: cp /etc/rc.d/init.d/functions /tmp vim /tmp/functions 命令模式下按“:”进入扩展模式输入 %s@\/etc\/sysconfig\/init@\/var\/log@ 63, 删除/tmp/functions文件中所有以#开头,且#后面至少有一个空白字符的行的行首的#号。 答案: vim /tmp/functions 命令模式下按“:”进入扩展模式输入 %s@^#”“\+.? @\1@ 64, 编写脚本/root/bin/systeminfo.sh,显示当前主机系统信息,包括主机名,IPV4,操作系统版本,内核版本,CPU型号,内存大小,硬盘大小。 答案: vim /root/bin/systeminfo.sh #******************************************************************** echo hostname echo ifconfig ens33 | egrep -o "\<(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5] )\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\>"|head -n1 echo cat /etc/centos-release echo uname -r echo lscpu |grep "^Model name.*" |cut -d: -f2|tr -s " " echo cat /proc/meminfo |head -n1 echo lsblk |grep '^sda'|tr -s " " "%"|cut -d% -f4 :wq 65, 编写脚本/root/bin/backup.sh,可实现每日将/etc/目录备份到/root/etcYYY-mm-dd中。 vim /root/bin/backup.sh cp -a /etc /root/etcdate +%F :wq 66,编写脚本/root/bin/disk.sh,显示当前硬盘分区中空间利用率最大的值。 答案: e=df|egrep ^/dev |tr -s " " ":"|cut -d: -f5|cut -d% -f1|sort -nr|head -n1 echo $e :wq 67, 编写脚本/root/bin/links.sh ,显示正连接本主机的每个远程主机的IPV4地址和连接数,并按连接数从大到小排序。 答案: vim /root/bin/linsk.sh a=cat access_log |egrep -o "\<(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\>"|sort|uniq -c|sort -nr echo $a 68, 编写脚本/root/bin/sumid.sh ,计算/etc/passwd 文件中的第10个用户和第20用户的ID之和。 答案: vim /root/bin/sumid.sh a=cat /etc/passwd | head -n10 |tail -n1|cut -d: -f3 b=cat /etc/passwd | head -n20 |tail -n1|cut -d: -f3 let c=a+b 或 d=$[ a+b ] echo $d 69, 编写脚本/root/bin/sumspace.sh ,传递两个文件路径作为参数给脚本,计算这两个文件中所有空白行之和。 答案: vim /root/bin/sumspace.sh a=cat f1 |egrep ^[[:space:]]*$ |wc -l b=cat f2 |egrep ^[[:space:]]*$ |wc -l let c=a+b 70, 编写脚本/root/bin/sumfile.sh ,统计/etc ,/var,/usr 目录中共有多少个一级子目录和文件。 答案:vim /root/bin/sumfile.sh a=ls /etc/ |wc -l b=ls /var/ |wc -l c=ls /usr/ |wc -l let d=a+b+c 71, 编写脚本/root/bin/argsnum.sh ,接受一个文件路径作为参数;如果参数个数小于1,则提示用户 “至少应该给一个参数”,并立即退出;如果参数个数不少于1,则显示第一个参数所指向的文件中的空白行数。 答案: vim /root/bin/argsnum.sh [ $# -lt 1] && echo “At least one parameter should be given” && exit [ $# -ge 1] && echo egrep "^[[:space:]]*$" $1|wc -l 73, 编写脚本/root/bin/hostping.sh ,接受一个主机的IPV4地址做为参数,测试是否可连通。如果能ping通,则提示用户 “该IP地址可以访问” ;如果不可ping通,则提示用户 “该IP地址不可访问”。 答案: vim /root/bin/hostping.sh [[ $1 =~ “\<(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5]]])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\>” ]] || echo { “IP error”;exit; } ping $1 && echo “This address can be accessed”|| echo “This address cannot be accessed” 74, 编写脚本/root/bin/checkdisk.sh , 检查磁盘分区空间和inode使用率,如果超过80%,就发广播警告空间将满。 答案: vim /root/bin/checkdisk.sh a=df |egrep ^/dev |tr -s " " ":" |cut -d: -f5 |cut -d% -f1|sort -nr|head -n1 [[ $a -ge 80 ]] && echo “zhao huo la ” || echo { “yi qie zheng chang”;exit; } 75, 编写脚本/bin/per.sh ,判断当前用户对指定参数文件,是否不可读并且不可写。 答案: [ -not -r $1 -a -not -w $1 ] && echo “bu ke du ” [ ?r$1?o?w$1 ] || echo “ke du ” 76,编写脚本/root/bin/excute.sh ,判断参数文件是否为sh后缀的普通文件,如果是,添加所有人可执行权限,否则提示用户非脚本文件。 答案: vim /root/bin/excute.sh [[ $1 =~ .*sh$ ]] && chmod +x $1 || echo "bu shi jiao ben wen jian " ]]> 28 /672.html#comments /feed/672.html 解决新浪图床外链出现异常的办法 /671.html /671.html Sun, 28 Apr 2019 00:19:00 +0800 刘大喵
  • 本站上的图片大多外链接自新浪微图床,大概是新浪图床做了防盗链吧,最近几天天突然发现文章中的图片无法显示。
    新浪外链图片提示.png
  • [collapse status="true" title="新浪相册外链异常提示"]
    403 Forbidden
    You don't have permission to access the URL on this server.
    Powered by Tengine
    [/collapse]

    • 但是复制图片链接直接在浏览器中打开,又可以看到图片,不知道这个是什么防护机制~
    • 其他站长也有反映:https://www.v2ex.com/amp/t/558006
    • 如果新浪真的限制外链,很多网站会遭殃。

    解决办法

    在<head></head>内增加一个<meta>标签面添加:

    <meta name="referrer" content="no-referrer">

    如果你使用的是WordPress或者typecho之类的程序,在主题头部模板header.php在在<head></head>内上面代码即可。

    不过貌似并不是所有浏览器都支持这个标签,比如IE,多亏微软自己都把IE抛弃了,国内那些所谓双核浏览器,在极速或者高速模式下也正常显示,至于这个“referrer”标签的作用是什么,请自行百度学习。

    另外,新浪微相册外链突然不能正常显示,什么原因造成的未知,上面的方法也只能说是临时的解决方案。

    2019年5月5日最后补充:博主已经把新浪图片都本地化,上述方法会失去很多原有的功能,例如无法评论等等。

    本文链接: /668.html
    本站文章采用 知识共享署名4.0 国际许可协议 进行许可,请在转载时注明出处及本声明!

    ]]>
    24 /671.html#comments /feed/671.html
    高科GP520系列交换机配置指南 /668.html /668.html Sun, 21 Apr 2019 11:58:00 +0800 刘大喵 前言

    [scode type="green"]

    • 本片文章介绍了高科GP520、T205系列交换机开局配置指南。
    • 该产品定位为底底底层业务接入设备。
    • 花里花俏的配置只会影响性能,登上只需一顿干配置能ping通即可。
    • 高科官方的给的配置文档问题太多所以周末抽空自己重写一份,时间仓促如有不正确请指出。@联系我
      [/scode]

    正题

    一、准备工作:

    1、设备默认的IP地址是10.XXX.XXX.XXX段的。电脑设置IP地址:10.44.44.44 (当然10.1.1.1可以)、子网掩码:255.255.255.0。
    2、注意:需要关闭防火墙、360杀毒等软件。
    3、到控制面板》》程序》》程序和功能》》打开或者关闭Windows功能:打开telnet客户端 ~和服务端~
    4、设备上面有4个拨码开关,正常情况不要拨码拨码会导致业务网管异常。1是恢复默认IP;2是恢复默认数据。

    二、安装网管软件iGoView

    下载地址: [button color="success" icon="" url="https://pan.baidu.com/s/13DZJkPclzEarMMwWqyVmWA" type=""]下载iGoView[/button]
    提取码:pc33
    运行setup.exe 一直下一步....
    ps:建议安装c盘,数据库安装Mysql

    三、登录设备:

    1.运行iGoView网管(需要管理员身份运行)
    2.登陆用户名称:00 密码 空
    [collapse status="false" title="图片"]登陆高科网管.png[/collapse]

    3.首次运行 iGoView网管 会提示您新增网管站,如果没有提示请手动添加 系统-通信参数-网管站信息-新增-填上上面准备工作设置好的电脑ip地址。
    [collapse status="false" title="图片"]设置网管站.png[/collapse]

    4.需要配置的新交换机网口接网线至电脑

    5.配置广播策略参数:设备-PTN设备相关维护-策略参数-广播包参数 如下图
    [collapse status="false" title="图片"]设置广播包参数.png[/collapse]

    6.如上操作后左边栏会自动发现新的设备,通常是 xx-xx-xx(10.x.x.x-GP520),你需要在电脑网卡设置一个同网段的ip地址 才能访问交换机 子网掩码默认为255.255.255.0
    [collapse status="false" title="图片"]左侧自动发现设备.png[/collapse]

    四、重要!配置网管和业务vlan

    如:业务vlan 157;网管vlan 136 网管IP地址 192.168.136.147/24

    [collapse status="ture" title="配置简要说明"]

    • 简要说明:交换机4网口2光口,网口为业务口光口为上联口 ;我们需要把vlan 157和136 透传至光口并加标签(即tag),业务vlan157设置在网口1并且去标签(即untag),网管vlan157里设置ip地址为192.168.136.147 子网掩码 255.255.255.0

    [/collapse]

    (1)利用iGoView网管配置

    1.配置管理IP:点击左侧发现的新设备GP520系列交换机(重启才生效!)如图
    [collapse status="false" title="图片"]设置网管ip,重启才生效! [/collapse]

    2.配置4个以太网端口隔离此步骤可忽略,但是官方建议隔离
    [collapse status="false" title="图片"]设置四个网口隔离.png [/collapse]

    3.配置网管vlan添加到上联口并加标签添加完vlan记得点配置!
    [collapse status="false" title="图片"]端口设置添加网管vlan.png [/collapse]

    4.配置业务vlan添加到上联口并加标签 添加完vlan记得点配置!
    [collapse status="false" title="图片"]端口设置添加业务vlan.png [/collapse]

    5.配置网口1尾用户接口提供用户使用,配置网口4管理接口方便现场登陆测试。添加完vlan记得点配置!
    [collapse status="false" title="图片"]
    网口1添加业务vlan去标签.png
    网口4添加网管vlan去标签.png
    [/collapse]

    6.建议最后检查一下所有端口配置vlan是否无误。记得点配置!

    [collapse status="false" title="图片"]检查一下端口配置所有端口是否正确.png [/collapse]

    7.配置802.1q vlan (必须)
    [collapse status="false" title="图片"]配置802.1q的vid.png [/collapse]

    8.保存配置
    [collapse status="false" title="图片"]保存配置.png [/collapse]

    补充说明:2-7 配置后无须重启马上生效,1 网管ip需要重启后生效。

    (2)使用命令配置

    命令配置无思科华为华三有效率,看心情更新 ::paopao:tieba_emotion_28::

    吐槽

    硬件

    主控:MT7620a(联发科单核560HZ百兆的SOC芯片)
    以太网芯片:AR8033-AL1A
    闪存:250128FVSG
    [collapse status="false" title="拆机图"]

    请输入图片描述
    感谢 @熊大大 提供的的硬件拆解图
    [/collapse]

    iGoView的Bug

    [collapse status="false" title="设置界面bug"]

    bug.png
    xp正常,win10会出现此bug,其他版本操作系统未实验
    [/collapse]

    本文参考: 高科官方文档
    本文链接: /668.html
    本站文章采用 知识共享署名4.0 国际许可协议 进行许可,请在转载时注明出处及本声明!

    ]]>
    13 /668.html#comments /feed/668.html
    实现网站页面秒开-预加载JS脚本instant.page /651.html /651.html Thu, 28 Mar 2019 19:26:00 +0800 刘大喵 本篇文章介绍了一个网站预加载的脚本instant.page

    √> 作用是可以预加载用户想访问的页面,当用户真正点击链接后,就会直接从缓存中读取,以此提升网站的访问速度。

    前言

    无意间看到这样一个脚本,传闻可以瞬间提高网站页面加载速度。我一直对网站加载速度的优化很感兴趣,于是便立即拿来试试,效果果然如说的那样,打开页面嗖嗖的 ::paopao:tieba_emotion_53::
    instant.page 原理的话我们不必深层了解,只需知道:

    • 在用户点击网站链接之前,他们将鼠标悬停在该链接上。当用户徘徊65毫秒时,他们将点击该链接有两个机会,因此 instant.page 此时开始预加载,平均超过 300 毫秒,以便页面预加载。
    • instant.page 是渐进式增强 - 对不支持它的浏览器没有影响。

    效果

    instant.page 对站内访问速度的提升的确很给力。然而它只会预加载自己的站内链接,而不会预加载其他外链。

    • 如图所示,当鼠标在左侧文章链接悬停超过 65ms 后,左侧 网络 即会对站内页面进行预加载(绿色部分)
    • 另外而悬停未超过 65ms 时,则不会进行预加载(红色部分)

    效果图

    • 使用 instant.page 只会预加载 html 页面,而不会加载图片等资源,因此点击预加载的页面是秒开的,图片在点击之后才会加载,不用担心与 lazyload 的各种不兼容问题。

    使用方法

    1.使用官方脚本

    只要把这行代码添加到网站的</body>标签之前即可。(由于脚本托管在国外,只建议国外的朋友使用,国内的朋友加载官方的资源会比较慢哦)

    <script src="//instant.page/1.2.2" type="module" 
    integrity="sha384-2xV8M5griQmzyiY3CDqh1dn4z3llDVqZDqzjzcY+jCBCk/a5fXJmuZ/40JJAPeoU"></script>

    2.自托管文件

    只需将下面这段 js文件 上传到自己服务器,然后在</body>标签之前根据路径添加下面的代码即可(强烈建议服务器在国内的朋友使用)
    下载地址:[button color="success" icon="glyphicon glyphicon-arrow-down" url="https://pan.baidu.com/s/1OHc7dhpHI1wvuyzpcX3Avw "]nstantclick-1.2.2.js[/button] 提取码:58cb

    <script src="`存放路径`/instantclick-1.2.2.js" type="module"></script>

    本文参考自:instant.page官网爱喝茶的康康左岸

    ]]>
    57 /651.html#comments /feed/651.html
    解决Windows连接PPTP/L2TP时无法连接上外网Internet的困扰 /647.html /647.html Sun, 24 Mar 2019 09:15:00 +0800 刘大喵 [scode type="green"]大家都知道使用VPN连接,我们可以利用现成的Internet网络通道,访问单位内部的资源,整个访问过程安全得如何就在同一个内网中一样。但是,在进行VPN网络连接时,我们时常会受到VPN默认路由的困扰,这种困扰往往会造成无法访问Internet网络等等的故障现象;很多朋友面对这样的困扰,无法找到有效的应对办法。[/scode]

    有鉴于此,本文就以Win10系统为操作蓝本,介绍一下如何经过设置,让VPN网络连接成功后笔记本电脑可以正常进行外网络访问!

    解决困扰的思路

    主要原因

    • VPN网络连接成功后,VPN服务器会为客户端分配一个默认网关同时优先级又比较高,那样一来系统就会“被迫”将数据全部跑往VPN服务器才去,造成不能正常上外网。

    解决思路

    • 为摆脱VPN默认路由,我们可以先对win系统的VPN客户端系统进行合适设置,让其继续优先使用以前的默认网关地址,确保VPN客户端系统上网访问时,仍然从本地出发使用专用上网通道访问Internet网络。
    • 之后!再采用手工方法添加一些静态路由,让系统在成功建立VPN网络连接后,可以通过VPN服务器访问单位内网的资源,如此一来就能实现VPN网络连接之后,既能上外网又能访问单位内部资源了!

    操作步骤

    1.禁用VPN的默认路由。

    开始菜单-设置-网络和internet(或者叫“网络连接”)-更改适配器选项-找到VPN连接的图标-右键-属性-网络- 选择“Internet协议版本4(TCP/IPV4)”-属性-高级-去掉勾选“在远程网络上使用默认网关”
    如图: (如果你还没有下图的vpn图标请参考此文创建

    [collapse title="操作步骤"]
    解决连接VPN无法上外网
    [/collapse]

    2.添加要访问的资源IP地址路由记录

    假如我要访问的内部资源IP是132.104.64.56120.80.16.74132.96.38.910.245.0.225,vpn服务器是 221.96.105.10 写路由表指过去vpn服务器就OK啦~~如下:

    (1)管理员身份运行 cmd
    (2)添加路由记录,复制指cmd命令行回车即可:

    route add -p  132.104.64.56 211.96.105.10 
    route add -p  120.80.16.74 211.96.105.10 
    route add -p  132.96.38.9 211.96.105.10 
    route add -p  10.245.0.225 211.96.105.10 

    (3)不好意思,没有了 ::paopao:tieba_emotion_90::

    版权属于:爱皮哇

    本作品采用知识共享署名 4.0 国际许可协议进行许可。

    ]]>
    32 /647.html#comments /feed/647.html
    网络篇-华为与思科做链路捆绑(聚合)的问题 /640.html /640.html Sun, 17 Mar 2019 09:07:00 +0800 刘大喵

    华为S5700 和 cisco6500 做 ETH-trunk 双链路捆绑拔插任意一条线都丢8个包,这个问题是项目做好很久之后一次偶然线路问题发现的。。。

    华为与思科

    拓扑(懒得画图):

    A(C2960)===》B(S5700) 通过 ETH-trunk 1 做链路捆绑 B(S5700)===》C(C6500) 通过 ETH-trunk 2 做链路捆绑 都是通
    过 2 层互联都是双链路.

    配置:

    C2960

    Switch#sh run int port-channel 1 
    Building configuration... 
    Current configuration : 54 bytes 
    ! 
    interface Port-channel1 
    switchport mode trunk 
    end 
    
    Switch#sh run int g0/47 
    Building configuration... 
    
    Current configuration : 85 bytes 
    ! 
    interface GigabitEthernet0/47 
    switchport mode trunk 
    channel-group 1 mode on 
    end 
    
    Switch#sh run int g0/48 
    Building configuration... 
    
    Current configuration : 85 bytes 
    ! 
    interface GigabitEthernet0/48 
    switchport mode trunk 
    channel-group 1 mode on 
    End 

    S5700

    \# 
    interface Eth-Trunk1 
    port link-type trunk 
    port trunk allow-pass vlan 2 to 4094 
    bpdu enable 
    \# 
    interface Eth-Trunk2 
    port link-type trunk 
    port trunk allow-pass vlan 2 to 4094 
    bpdu enable 
    \# 
    interface GigabitEthernet0/0/1 
    eth-trunk 1 
    undo ntdp enable                         
    undo ndp enable 
    \# 
    interface GigabitEthernet0/0/2 
    eth-trunk 1 
    undo ntdp enable 
    undo ndp enable 
    \# 
    \# 
    interface GigabitEthernet0/0/13 
    eth-trunk 2 
    undo ntdp enable 
    undo ndp enable 
    \# 
    interface GigabitEthernet0/0/14 
    eth-trunk 2 
    undo ntdp enable 
    undo ndp enable 
    \# 

    C6500

    BJ-BS02-6509#sh run int port-channel 100 
    Building configuration... 
    Current configuration : 142 bytes 
    ! 
    interface Port-channel100 
    description to test 
    no ip address 
    switchport 
    switchport trunk encapsulation dot1q 
    switchport mode trunk 
    end 
    BJ-BS02-6509#sh run int g2/41 
    Building configuration... 
    
    Current configuration : 173 bytes 
    ! 
    interface GigabitEthernet2/41 
    description to test 
    no ip address 
    switchport 
    switchport trunk encapsulation dot1q 
    switchport mode trunk 
    channel-group 100 mode on 
    end 
    
    BJ-BS02-6509#sh run int g2/42 
    
    Building configuration... 
    
    Current configuration : 173 bytes 
    ! 
    interface GigabitEthernet2/42 
    description to test 
    no ip address 
    switchport 
    switchport trunk encapsulation dot1q 
    switchport mode trunk 
    channel-group 100 mode on 
    end 

    故障现象描述:

    A 下的主机 ping C 上的一个 ip 地址在捆绑做完配置候(未断线)通不丢包
    当断 AB 之间的一条链路丢 2 个包(拔插各一个正常)
    当断 BC 之间一条链路的时候丢 8 个包(拔插各 8 个不正常)

    处理过程

    检查配置基本没有问题:换场景测试我们把 A 接 B 的口和 C 接 B 的口对调配置不变断线 ping
    结果还是和开始一样在断 BC 链路的时候丢包 8 个(拔插各八个不正常)
    Cisco A 和 C 直接对接 ping 断线测试(配置不变)拔插各丢一个包正常
    通过拨打 400 客服(单号 2814229)给他说明情况和捆绑配置同时他让做了流量统计他们给出初步
    结论(57 和 65 之间物理线路问题接口问题以及不同厂商兼容问题)

    继续排查:

    保持上面的配置不变继续测试(捆绑接口都是放行 vlan all)
    通过上面的排查基本可以确定问题在 B 到 C 这两个交换机上。
    故先测 B 到 C 之间捆绑链路是否有问题:

    情景一

    • 在 B 交换机 S5700 上接了一个 pc 机把该接口划分在业务 vlan 下 ping 自己在 Cisco 交换机 6500上的网关
    • 现象: 不断线不丢包 断其中任意一条线丢 8 个包(拔线时丢 8 个再把链路恢复插上的时候也丢 8 个)

    情景二

    在交换机 B s5700 上配置了一个 vlanif 接口也是用该接口地址直接 ping cisco 交换机 6500 上的网关

    • 现象: 不断线不丢包 断其中任意一条线丢一个包(拔插个一个)
    • 得出结论:B 和 C 也就是 S5700 和 cisco6500 之间的捆绑链路没有问题

    情景三

    • 我们又在交换机 A 上配了一个 vlanif 接口用该地址 ping C 交换机 cisco6500 上的网关地址
    • 现象: 不断线不丢包 断 A 和 B 之间的链路一根线丢 1 个包(拔的时候丢 1 个再插上丢一个) 断 B 和 C 之间链路任意一根线丢 8 个包(拔插各 8 个包)

    情景四

    • 用 A 上的 vlanif 地址 ping B 交换机上的 vlanif 地址

    现象:

    • 不断线不丢包 断 A 和 B 之间任意一条链路丢一个包(拔插各一个)
    • 得出结论:可能业务 vlan 的问题,但是我们都是放行所有 vlan 和技术以及华为 400 沟通之后捆绑
    • 接口不放行所有 vlan 只放行业务 vlan

    修改配置:

    S5700

    \# 
    interface Eth-Trunk1 
    port link-type trunk 
    port trunk allow-pass vlan 4 999 
    bpdu enable 
    \# 
    interface Eth-Trunk2 
    port link-type trunk 
    port trunk allow-pass vlan 4 999 
    bpdu enable 
    在 A 和 C 上也只放行业务 vlan 4 999 

    测试:把两台 pc 接在交换机 A c2960 上分别归在 vlan4 和 vlan999 然后 ping C 交换机 cisco6500
    上的网关地址

    现象:
    不断线不丢包 断 A 和 B 之间的任意一条链路丢一个包(拔插个一个) 断 B 和 C 之间的任意一条链路个丢一个包(拔插个一个)
    A 和 B 与 B 和 C 之间链路各任意断一条丢两个包(拔插各两个)
    该测试现象正常

    把现象反馈给 400 技术沟通得出结论:不同厂商之间兼容性问题,还有就是放行 vlan all 不安全容
    易出问题实际工程中几乎不这样做 主要结论归结不同厂商 BUG。

    小结

    1.可能配置出错,物理线路有问题,接口模块问题,工作速率工作模式(全双工半双工)不同厂
    商之间兼容性问题还有就是放行 vlan。。。。
    2.在配置链路捆绑的时候我们尽量不要放行 vlan all 这样安全性低以及容易出错,只需要具体
    放行业务 vlan 就可以了,同时与异厂商做对接时的明白设备通用协议考虑到兼容性问题。

    ]]>
    9 /640.html#comments /feed/640.html
    常见的几种华为PON ONU MA5616、MA5620等配置 /638.html /638.html Mon, 11 Mar 2019 18:08:00 +0800 刘大喵
  • 本文主要记录一下开局脚本,记性不好,以免遗忘,也许正好有人需要呢?也可以帮到人 ::paopao:tieba_emotion_93::
  • 常见的几种华为ONU MA5616、MA5620等配置

    MA5620配置

    数据通信部分

    vlan 1001 to 1024 mux
    y
    
     port vlan 1001 to 1024 0/0 1
    y
    
    
    
    multi-service-port  from-vlan 1001 port  0/1  1-24 user-vlan  untagged  rx-cttr 6 tx-cttr 6 
    y
     
    
    multi-service-port from-vlan 1001 board 1 user-vlan untagged rx-cttr 6 tx-cttr 6 
    y

    语音部分

    vlan 3807 smart
    
    port vlan 3807 0/0 1
    
    interface vlanif 3807 
    
     ip address 10.61.127.136 255.255.255.128
    
    quit
    
    protocol-8021p-pri 6 vlan  3807 
    
    voip
    
     ip address media 10.61.127.136 10.61.127.129
    
     ip address signaling 10.61.127.136
    
    qos vlan  media 10.61.127.136 priority 6
    
    qos vlan  signaling 10.61.127.136 priority 6
    
    quit
    
    interface h248 0
    Y
    
    if-h248 attribute mgip 10.61.127.136 mgport 2944 transfer udp primary-mgc-ip1 221.4.12.196 primary-mgc-port 2944 mg-media-ip1  10.61.127.136 start-negotiate-version 1 
    
    
    if-h248 attribute mgc-domain-name1 FS.GD.SS-HW-1.CNC.cn mgc-domain-name2 FS.GD.SS-HW-2.CNC.cn primary-mgc-ip1 221.4.12.196 primary-mgc-port 2944 secondary-mgc-ip1 221.4.13.196 secondary-mgc-port 2944
    
    
    mg-ringmode add 0 10 26
    
    digitmap-timer start 20
    
    digitmap-timer short 3
    
    digitmap-timer long 3
    
    digitmap-timer duration 4000
    
    mg-software parameter 13 2
    
    reset coldstart
    y
    quit
    
    
    
    esl user 
    mgpstnuser batadd 0/1/1 0/1/24  0 terminalid 0 
    
    
    
    quit
    
    pstnport  
    
    pstnport  attribute batset 0/1/1 0/1/24 reverse-pole-pulse-level 300
    
    pstnport electric batset 0/1/1 0/1/24 current 2 
    
    quit
    
    board reset 0/1
    y
    
    ring check enable
    autosave interval on
    autosave interval 1440   
    dns server 10.15.55.55
    dns server 10.15.55.88
    
    undo rollback
    y
    
    dsp attribute jitter-buffer init-adapt-jb 20 
    
    
    fax-modem parameters rfc2198-start-mode disableRfc2198SmartStartup
    
    fax parameters workmode thoroughly flow v5  
    
                                                                                                       
    ip route-static 221.4.12.0 255.255.255.0  10.61.127.129
    
    ip route-static 221.4.13.0 255.255.255.0  10.61.127.129
    
    ip route-static 221.4.15.0 255.255.255.192  10.61.127.129
    
    ping   221.4.12.196    //测试是否通至软交换
    

    MA5626配置

    与MA5620大同小异直接copy即可~

    MA5616配置

    数据部分

    board confirm 0
    
    vlan 1001 to 1128 mux
    y
    
     port vlan 1001 to 1128 0/0 1
    y
    
    
    multi-service-port from-vlan 1001 board 3 vpi 0 vci 35 user-vlan untagged rx-cttr 6 tx-cttr 6 
    y
    
    multi-service-port from-vlan 1033 board 4 vpi 0 vci 35 user-vlan untagged rx-cttr 6 tx-cttr 6 
    y
    
    multi-service-port from-vlan 1161 board 2 vpi 0 vci 35 user-vlan untagged rx-cttr 6 tx-cttr 6 
    y
    
    adsl line-profile quickadd 2 basic-para all trellis 1 bitswap 0 0 channel interleaved 16 6 adapt at-startup snr 6 0 31 6 0 31  rate 32 2048 32 512 name 2M_inter
    
    adsl line-profile quickadd 3 basic-para all trellis 1 bitswap 0 0 channel fast adapt at-startup snr 6 0 31 6 0 31  rate 32 2048 32 512 name 2M_fast
    
    adsl line-profile quickadd 4 basic-para all trellis 1 bitswap 0 0 channel interleaved 16 6 adapt at-startup snr 6 0 31 6 0 31  rate 32 4096 32 512 name 4M_inter
    
    adsl line-profile quickadd 5 basic-para all trellis 1 bitswap 0 0 channel fast adapt at-startup snr 6 0 31 6 0 31  rate 32 4096 32 512 name 4M_fast
    
    adsl line-profile quickadd 6 basic-para all trellis 1 bitswap 0 0 channel interleaved 16 6 adapt at-startup snr 6 0 31 6 0 31  rate 32 6144 32 512 name 6M_inter
    
    adsl line-profile quickadd 7 basic-para all trellis 1 bitswap 0 0 channel fast adapt at-startup snr 6 0 31 6 0 31  rate 32 6144 32 512 name 6M_fast
    
    adsl line-profile quickadd 8 basic-para all trellis 1 bitswap 0 0 channel interleaved 16 6 adapt at-startup snr 6 0 31 6 0 31  rate 32 8192 32 512 name 8M_inter
    
    adsl line-profile quickadd 9 basic-para all trellis 1 bitswap 0 0 channel fast adapt at-startup snr 6 0 31 6 0 31  rate 32 8192 32 512 name 8M_fast
    
    adsl line-profile quickadd 10 basic-para all trellis 1 bitswap 0 0 channel interleaved 16 6 adapt at-startup snr 6 0 31 6 0 31  rate 32 10240 32 1024 name 10M_inter
    
    
    
    ring check enable
    autosave interval on
    autosave interval 1440 
    
    interface adsl 0/2
     deactivate  all 
     activate  all  profile-index 10
    quit
    
    interface adsl 0/3
     deactivate  all 
     activate  all  profile-index 10
    quit
    
    interface adsl 0/4
     deactivate  all 
     activate  all  profile-index 10
    
     quit

    语言部分

    
    vlan 3875 smart
    
    port vlan 3875 0/0 1
    
    interface vlanif 3802 
    
     ip address  10.60.126.194 255.255.255.192
    
    quit
    
    protocol-8021p-pri 6 vlan  3802
    
    
    voip
     ip address media 10.60.126.194 10.60.126.193
     ip address signaling 10.60.126.193
    
    qos vlan  media 10.60.126.194 priority 6
    
    qos vlan  signaling 10.60.126.194 priority 6
    
    quit
    
    interface h248 0
    Y
    
    if-h248 attribute mgip 10.60.126.193 mgport 2944 transfer udp primary-mgc-ip1 221.4.12.196 primary-mgc-port 2944 mg-media-ip 10.60.126.193 start-negotiate-version 1 
    
    
    if-h248 attribute mgc-domain-name1 FS.GD.SS-HW-1.CNC.cn mgc-domain-name2 FS.GD.SS-HW-2.CNC.cn primary-mgc-ip1 221.4.12.196 primary-mgc-port 2944 secondary-mgc-ip1 221.4.13.196 secondary-mgc-port 2944
    
    
    mg-ringmode add 0 10 26
    
    digitmap-timer start 20
    
    digitmap-timer short 3
    
    digitmap-timer long 3
    
    digitmap-timer duration 4000
    
    mg-software parameter 13 2
    
    reset coldstart
    y
    quit
    
    
    
    esl user 
    mgpstnuser batadd 0/1/0 0/1/31  0 terminalid 0
    
    
    quit
    
    pstnport  
    
    pstnport attribute batset 0/1/0 0/1/31 reverse-pole-pulse enable reverse-pole-pulse-level 300  
    
    quit
    
    board reset 0/1
    y
    
    ring check enable
    autosave interval on
    autosave interval 1440   
    dns server 10.15.55.55
    dns server 10.15.55.88
    
    undo rollback
    y
    
    dsp attribute jitter-buffer init-adapt-jb 20 
    
    
    fax-modem parameters rfc2198-start-mode disableRfc2198SmartStartup
    
    fax parameters workmode thoroughly flow v5  
    
                                                                                                       
    ip route-static 221.4.12.0 255.255.255.0  10.61.122.1
    
    ip route-static 221.4.13.0 255.255.255.0  10.61.122.1
    
    ip route-static 221.4.15.0 255.255.255.192  10.61.122.1
    
    ping   221.4.12.196    \\test ms
    ]]>
    17 /638.html#comments /feed/638.html
    Typecho通过阿里邮件推送和LoveKKComment插件实现评论邮件通知 /637.html /637.html Fri, 08 Mar 2019 16:45:00 +0800 刘大喵 √> 这里推荐一款新的评论邮件通知插件 LoveKKComment,插件的接口更加丰富:SMTP、SendCloud 服务、Alicloud DirectMail,且附带博客用户密码找回功能,作者至今仍在维护。

    弃掉 WordPress 选择 Typecho 就是看中了它轻便快捷,非常适合作为个人记录的博客。使用过程中有了很多新需求,都在社区找到了对应的插件实现。社区里大部分参考都是使用CommentToMail这款插件,即使后台模拟发信能够成功,但是经常会出现各种‘玄学’的问题 例如回复评论没有发出邮件.... ::aru:speechless::

    • 本文使用 Alicloud DirectMail 的 API 接口实现邮件推送。三种方式的选择见后文。

    Typecho通过Alicloud和插件LoveKKComment实现评论邮件通知

    实现环境

    • 操作系统:CentOS7
    • 技术基础 默认已有私有服务器,拥有私有域名,安装了博客 Typecho 且有 Linux 基础
    • 阿里云邮件推送服务(Alicloud DirectMail):官方帮助文档
    • LoveKKComment:项目地址 - github

    开通Alicloud DirectMail服务

    • 阿里云推送的作用是帮你把插件生成的邮件内容推送至评论时留下的邮箱中。通过阿里云可以把你喜欢的域名(一般是你博客域名)作为发信域名,类似于admin@qq.com中的qq.com部分,你还能自由设置前缀,生成发信地址。本博设置了admin@mail.ipwa.cn为发信地址。是的,你现在评价后,就能收到这个地址发来的邮件,试一下?
    • 配置过程需要配置发信域名,并且验证;配置发信地址;并且取得阿里云平台的授权。

    发信域名

    请移步阿里云教程:新建发信域名

    教程很详细,特别注意两点:
    二级域名:建议使用二级域名,如mail.ipwa.cn,避免对顶级域名ipwa.cn产生影响
    验证时间:DNS 配置后的生效时间是 10 min,需要等待生效之后发信域名的验证才能通过

    发信地址

    • 请移步阿里云教程:新建发信地址
    • 特别注意一点:发信类型选择 触发邮件

    获取授权 —— accesskeys

    获取阿里云平台的 API 授权,这样插件才有权调用邮件推送的功能。这里只需要DirectMail 权限,所以只需要子账户的 accesskeys即可。

    进入控制台,鼠标移动至右上角,选择 accesskeys ▼

    11.jpg

    根据提示选择开始使用子账户 AccessKey ▼

    22.jpg

    然后会提示你开通RAM访问控制 开通集客

    创建用户 ▼
    44.jpg

    输入短信验证码之后,记录生成的AccessKey ID和AccessKey Secret

    55.jpg
    授权出添加一下此两项权限

    • AliyunDirectMailFullAccess 管理邮件推送(DirectMail)的权限
    • AliyunDirectMailReadOnlyAccess 只读访问邮件推送(DirectMail)的权限

    安装插件 LoveKKComment

    安装方式同常规插件安装。详见:Typecho评论邮件通知插件 - LoveKKCommentv1.0.5

    安装and设置

    1. 通过git clone将插件下载至Typecho插件目录./usr/plugins中,目录名称更改为LoveKKComment
    2. 后台激活插件
    3. 选择发信接口:阿里云推送
    4. 发件邮箱地址和邮件回复地址同 Alicloud DirectMail 中的设置
    5. 填入对应的DM接入区域、Accesskey ID、Accesskey Secret ▼

    33.jpg

    三种方式

    SMTP。 这种方式通过各种邮件服务商提供的 SMTP 接口发送邮件,优势是不需要设置发信域名,用自有的QQ、163 邮箱直接发信;不足我自己体验下来,评论提交速度会变慢,且有时无法触发发信。

    Send Cloud。 邮件推送服务商,类 Alicloud DirectMail 服务。

    Alicloud DirectMail。 其在 Typecho 后台的配置更为简单。且阿里云服务稳定, 相应速度快,基本上我评价之后就能收到邮件。在阿里云后台能够看到发信统计,分析等。推荐这种方式。

    小提示

    插件里面的发信内容能够自定义,模板文件在文件夹./usr/plugins/LoveKKComment/theme中,分别为:

    • approved.html:邮件审核通过通知模板
    • author.html:文章评论通知作者模板
    • reply.html:评论回复通知被回复者模板

    在先前测试中,默认模板发送到QQ 邮箱会被认为广告垃圾邮件,建议对模板作一些修改,把类似自动、系统创建等词语替换,保证信件顺利到达。

    本文主要内容参考于网上的几位大佬,插件作者爱喝茶的康康,仅供用于学习和交流,若有侵权请邮件联系本站!i@t1i.cn

    ]]>
    40 /637.html#comments /feed/637.html